Install PHP Manager 5.2.17 on iis7 add extension mssql

Dec 8, 2011 at 4:53 AM


I have install php manager 5.2.17 on iis7 (non-thread zipped one) and i have uncomment the mssql extension. But when i load the phpinfo page the mssql is not shown on the page, can anyone help me?

Dec 8, 2011 at 5:24 AM

I am working on windows server 2008 iis7 platform. I am trying to connect to ms sql database from php. I have made the required changes to the php.ini file to enable mssql dll. When i do a phpinfo() command through the windows command promt, I can see that ms sql is enables and everything is good. However, when i perform phpinfo() using iis7 interface (where i am asked to specify the website first), I see that ms sql is not enabled. I am not able to connect to my database through my website for this reason?

Dec 9, 2011 at 5:28 AM

Hi, could anyone help?

Dec 9, 2011 at 7:01 AM

Hi Gfaraaz,

Please do not use mssql extension to connect to sql server. Instead use the sqlsrv extension developed by Microsoft -

Oct 8, 2013 at 10:16 PM

I've been busting my balls for 4 hours now and I can't get the sql dll to register when I do a phpinfo()
I've downloaded both ver3 and ver2 from Microsoft
I can't get any database connectivity of course
I have the ext directory specified in php.ini

-Windows 2008 R2 with PHPManagerForIIS-1.2.0-x64 installed
-PHP works fine
-when I go to extensions in PHP Manager, I can see that the dll is loaded
-I've tried the following dlls by copying to the ext dir and setting in php.ini, then an iisreset

any suggestions would be greatly appreciated...