10
Vote

Refuses to install for WTP10

description

http://imgur.com/a/QN4iM

I am a WTP10 user. I’m running build 10049 at the moment. I suspect that the installer is doing something like substring-ing the version of IIS before numerically comparing it (maybe it’s checking if 0>7 instead of 10>7.) or listing exact compatible major versions of IIS. Maybe it needs actual porting, but it looks like a simple version check is failing…

INFO : [04/02/2015 11:55:27:992] [VsdLaunchConditions ]: Getting the condition to evaluate...
INFO : [04/02/2015 11:55:27:992] [VsdLaunchConditions ]: MsiRecordGetStringW - Fetching value...
INFO : [04/02/2015 11:55:27:993] [VsdLaunchConditions ]: MsiRecordGetStringW - Getting value from column '1'...
INFO : [04/02/2015 11:55:27:993] [VsdLaunchConditions ]: Evaluating condition 'IISREGISTRYVALUE >= "#7"'...
INFO : [04/02/2015 11:55:27:994] [VsdLaunchConditions ]: RESULT: Condition is false.
INFO : [04/02/2015 11:55:27:994] [VsdLaunchConditions ]: MsiRecordGetStringW - Fetching value...
INFO : [04/02/2015 11:55:27:994] [VsdLaunchConditions ]: MsiRecordGetStringW - Getting value from column '2'...
INFO : [04/02/2015 11:55:27:995] [VsdLaunchConditions ]: MsiSetPropertyW - Setting Property Value...
MSI (s) (3C!04) [11:55:27:996]: PROPERTY CHANGE: Adding HideFatalErrorForm property. Its value is 'TRUE'.
INFO : [04/02/2015 11:55:27:996] [VsdLaunchConditions ]: MsiSetPropertyW - Setting property 'HideFatalErrorForm' to 'TRUE'.
INFO : [04/02/2015 11:55:27:996] [VsdLaunchConditions ]: Checking a launch condition...
INFO : [04/02/2015 11:55:27:997] [VsdLaunchConditions ]: A launch condition has already fired. My work is done here.
ERROR : [04/02/2015 11:55:27:997] [VsdLaunchConditions ]: Custom Action failed with code: '1603'
INFO : [04/02/2015 11:55:27:998] [VsdLaunchConditions ]: Custom Action completed with return code: '1603'
CustomAction VSDCA_VsdLaunchConditions returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 11:55:28: VSDCA_VsdLaunchConditions. Return value 3.
Action ended 11:55:28: INSTALL. Return value 3.

file attachments

comments

binki wrote Apr 2, 2015 at 10:11 PM

I can’t even open the .vdproj for editing in VS 2015 CTP 6. So this project needs to be ported to WIX or something regardless?

wrote Apr 14, 2015 at 8:53 PM

FourierSerious wrote Jun 17, 2015 at 6:44 PM

The setup program checks that the registry value HKLM/System/CCS/Services/W3SVC/Parameters/MajorVersion is >= 7. The value in the registry is 0xA, which I am assuming is the problem. For a workaround, change the registry value to 9 (or 8 or 7) and PHP Manager for IIS should install correctly. [insert standard disclaimer about editing the registry]

wrote Jul 5, 2015 at 5:54 AM

wrote Aug 11, 2015 at 9:37 AM

wrote Aug 31, 2015 at 6:49 AM

wrote Sep 18, 2015 at 2:24 AM

VadimashRS wrote Oct 3, 2015 at 12:48 PM

Hello, I compiled specifically new installers for IIS8-8.5 IIS10

Image
Image
Image
Image

PHP Manager 1.4 for IIS 10

PHP Manager 1.3 for IIS 8-8.5

Thanks for the support:
PayPal:xxxvcojocarixxx@gmail.com
WMZ:Z162199218738
WMR:R250322323111
WME:E241475837014

AndrewBolton wrote Nov 14, 2015 at 12:34 PM

Also trying to install Windows 10, but a 32-bit machine.

Can't find the registry key in the registry. What am I missing?

The compiled installers by VadimashRD dont work.

Any help appreciated

VadimashRS wrote Jan 9, 2016 at 6:19 PM

AndrewBolton need instaler for x32 bit ver systems?

VadimashRS wrote Jan 9, 2016 at 6:39 PM

1.3.0 x86
http://1drv.ms/1UFe3Wf
1.4.0 x86
http://1drv.ms/1UFeek8


Plase test and report
No have time for making virtul machines.
SRY 4 my eng :D

VadimashRS wrote Jan 9, 2016 at 7:18 PM

Sorry new link for
1.3.0 x86
http://1drv.ms/1VU8HYv

wrote May 14, 2016 at 10:27 PM

wrote Dec 20, 2016 at 9:26 PM

wrote Feb 1 at 12:20 AM

wrote Feb 25 at 12:21 PM